No announcement yet.

Update broke arena?

  • Filter
  • Time
  • Show
Clear All
new posts

    Update broke arena?

    Just updated bring google play store and started up the game. Introducing arena. Huh, weird since that was already a thing, but mail also says I'll get 50 gems for winning a match. Great!

    ​​​​​​I pick an opponent, click fight, it loads and...nothing. I try to move and get an error message, out of memory? I don't think so, it worked before the update.

    I try it again. Same thing. Worked perfectly before the update

    Am I the only one getting this, or did the update break the arena for you, too?

    ​​​​​​​Guess I'll go and see if anything else broke. :-(

    This is caused by a known memory leak. Try the following (in order):
    1. If you haven't already, create an Eternium account using the "save now" button on the left side of the game's main screen.
    2. Open your app manager and find Eternium.
    3. Force close the app.
    4. Clear the app data/cache.
    5. Restart your device.
    6. Launch the game and login.
    7. Select the first level in Act 1, tap "play", then allow the updates to completely install before tapping "start".

    Once the updates have installed, you should be able to play normally. You can avoid memory heap errors by not leaving the game open for too long. You should close and reopen the game every now and again to flush the memory.


      I don't recall creating an account, but there's no "save now" option that I see. There's a logout option. Does that mean I have an account? Just a little leery of clearing data, you know?


      • Nhat
        Nhat commented
        Editing a comment
        If you see the [Logout] button and a name at the bottom of the left-panel, then yes, you have already made a game account. Press on the status light at the top right to make sure your game is saved to device and server. Given that you don't remember making the account, you might need to reset the password... could try to logout and login again first to see if you can remember the password though...