No announcement yet.

Crashes/Bugs involving the inventory hotkey on Steam(a.k.a. "Not the inventory button again!")

  • Filter
  • Time
  • Show
Clear All
new posts

    Crashes/Bugs involving the inventory hotkey on Steam(a.k.a. "Not the inventory button again!")

    Game version: 1.5.95
    Windows/IOS/Android + version: windows Steam PC
    Reproducible: 5/5

    Crash 1 (object drag + inv) :
    1. Open inventory
    2. Start dragging any item from storage/equipped items/inventory; OR Start dragging any ability in the ability tab; OR Start dragging any companion in the companion tab.
    3. Press Inventory hotkey while dragging.
    4. crash!

    Crash 2 ( legendary salvage + inv) :
    1. Open salvage menu
    2. Press Legendary salvage
    3. Press the inventory hotkey
    4. Press "Yes" after 5 seconds elapse
    5. Crash!

    Crash 3 (misty island gem message + inv) :
    1. Go to "6.Misty island" While you still haven't received 5 stars on this map
    2. kill gorgona.
    3. Enter the portal back home
    4. You get a prompt saying you earned 1/2/4 gems
    5. Press your inventory hotkey at this point, before closing that prompt.
    6. Crash

    Crash 4 (pvp chest + inv) :
    1. Go to pvp arena
    2. Win a chest.
    3. Open the chest and click on all the rewards so they display.
    4. a "Done" button appears.
    5. Click your inventory hotkey
    6. Crash.

    Bug 5 (pvp opponent seach + inv) :
    1. Go to pvp arena.
    2 Search for opponent
    3. When you get an opponent, or while you're viewing one of the 3 opponents, click the inventory hotkey
    4. At this point you lose your fighting chance and instantly exit the arena and go to your inventory without any prompt that you'd lose your fighting chance!!!

    Bug/Crash 6 (locked chest + inv):
    1. go to any story map and find a chest that can be unlocked with gems.
    2. click on "inspect chest", or whatever the message is, so that you can see the contents of the chest before paying gems to unlock it.
    3. When you see the contents, press your inventory hotkey.
    4. Bug - you open your inventory, but after that you can't move. Even when you close the inventory, your character is stuck. Opening the map/settings/inventory Doesn't unstick you. Quitting the story map and going to town still doesn't fix the problem - you cannot move in town. The only solution I saw was to quit and restart the game. (maybe changing the character might have sovled it? You can test if that will work, but it doesn't matter, your current playthrough is still broken).

    This happened to me during ANB(I wanted to buy 1 mark of titans for 64 gems instead of buying it from town for 200) and I was stuck on the map with my timer running

    Bug 7(Visual: quest + trader + inv):
    1. Accept any quest from town.
    2. Go to any trader.(example - click on Mitzu => sell anything, also happens with merchant, tavern, ruby, recipe trader )
    3. Press the inventory hotkey while you're in the trading window.
    4. Bug - your inventory opens, and the quest button is displayed on top of your inventory, you can actually click on it and go to the quest menu.
    That shouldn't happen. Expected behavior is the quest to stay below the inventory while the inventory is opened.
    Click image for larger version  Name:	image.png Views:	8 Size:	279.2 KB ID:	216468

    Crash 8 ( Kara kill message + inv):
    1. Go to 4-55: The Underworld on normal or Heroic difficulty(Legendary might also work? I don't remember what message you get there)
    2. Kill the final boss Kara
    3. You get a message that you unlocked the next difficulty
    4. You guessed it - press your inventory hotkey at this point.
    5. Crash!

    I'll post more if I run to any other crashes. Those should keep you busy for a while.

    Last edited by martosss; 02-21-2023, 11:39 PM.

    Bug 9 (training dmg details + inv):
    1) Go to training area
    2) Select single enemy damage training
    3) click on "details" to see a damage report
    4) click the inventory hotkey
    5) Bug! At this point your inventory opens and after closing it you can't operate any of the buttons for details/damage reset / inventory/settings in the bottom middle of the screen. Only map restart solves it.
    Last edited by martosss; 02-21-2023, 11:39 PM.