Eternium
Eternium

Announcement

Collapse
No announcement yet.

ERROR (Marmalade) v8.6.0 Heap 0 out of memory

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ERROR (Marmalade) v8.6.0 Heap 0 out of memory

    Hi,

    been experiencing heap 0 recently. happened to me most of the time, especially when I am running trials.

    have tried:
    *uninstall and reinstalling the game
    *turning multicore OFF. tried it as well with ON
    *frame limiter ON, and OF
    *tried lowering the graphics.

    I haven't experienced the bug before the latest iOS update.
    the update seems to mess up alot, including the arcane bolts.

    gaming environment:
    *iOS 10.2 on 64gb.
    *mage (pure arcane bolt) <- maybe the misfiring and floating arcane bolts are causing out of memory since it is not disappearing from map.


    Click image for larger version

Name:	heap0.jpg
Views:	1
Size:	179.7 KB
ID:	47829

  • #2
    This is a known issue in game version 1.2.26. Fixes are included in 1.2.27, which will be available when Apple approves it.

    Comment


    • #3
      This bug occured to me on the PC version while farming story for gems, i.e. loading a lot of different maps after another. The screenshot shows the error message while loading level 55. Bug occurs rarely and only after long farming sessions.

      Comment


      • #4
        C/C++ Heap: "A very simple explanation is that the heap is the portion of memory where dynamically allocated memory resides (i.e. memory allocated via malloc ). Memory allocated from the heap will remain allocated until one of the following occurs: The memory is free 'd. The program terminates."

        Often this is related to how many programs are currently in memory, whether active or suspended. I suspect that closing and reopening the program might clear the heap, which is currently "filled" with "farmed objects."
        Last edited by lmcelhiney; 09-04-2019, 04:59 PM.

        Comment


        • #5
          Well this is correct. At first i thought it is due to memory leaks, i.e. objects that not get deleted properly. But then i noticed, that the amount of free heap memory is larger than the requested amount. So the bug might be in estimating the free heap size, which could be on the engine. Hopefully the devs lifes will get easier with unreal engine.

          Comment


          • #6
            This happens when the game has been running and you've been doing the same thing repeatedly. A quick cache dump (app reset on Windows) fixes it. Then, you can avoid it by closing the app every now and again.

            Comment

            Working...
            X