Eternium
Eternium

Announcement

Collapse
No announcement yet.

What no adverts?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    What no adverts?

    Since the season start I have not had a single advert, I have had only a handful of mystery boxes all of which have produced either a gem or gold despite playing through to my current season level 8. Have ads been switched off? I have checked that the option is still selected in the settings but still no ads. I was wondering if it was a way of reducing the number of gems to match during the season event but I couldn't see them losing the advertising revenue for three months.
    If this is a glitch does anyone know how to remedy it?

    #2
    Try resetting your advertising ID

    Comment


      #3
      Where would I find that?

      Comment


        #4
        I have head that is effective from an Android POV. However, I use iOS which does not offer such an option. When such an anomaly has occurred for me (such as on the 2nd day of Season 1), I just reinstall the app. This always seems to correct the issue and I will immediately start receiving Ad boxes again.

        Comment


          #5
          Originally posted by lmcelhiney View Post
          I have head that is effective from an Android POV. However, I use iOS which does not offer such an option. When such an anomaly has occurred for me (such as on the 2nd day of Season 1), I just reinstall the app. This always seems to correct the issue and I will immediately start receiving Ad boxes again.
          I'm on Android, and this is the only reliable way I've been able to restart the ad boxes for months. It's really a pain; I'd be OK with the 50 ads/day limit if they'd just freaking work, but sometimes I have to reinstall the game 2 or 3 times just to run my dailies & ads. (not even gonna talk about the bugged ads and 'dud' boxes!)

          (BTW, I have tried all the other suggestions from the forum, like resetting your Google advertising ID, clearing cache, force-closing, rebooting, etc.)

          Comment


            #6
            Originally posted by Blaydon View Post
            Where would I find that?
            On Android: Settings -> Google -> Ads ->Reset Advertising ID
            Close the game and clear from background (recent app list) before doing it.

            Comment


              #7
              Originally posted by ScabbyNuisance View Post

              I'm on Android, and this is the only reliable way I've been able to restart the ad boxes for months. It's really a pain; I'd be OK with the 50 ads/day limit if they'd just freaking work, but sometimes I have to reinstall the game 2 or 3 times just to run my dailies & ads. (not even gonna talk about the bugged ads and 'dud' boxes!)

              (BTW, I have tried all the other suggestions from the forum, like resetting your Google advertising ID, clearing cache, force-closing, rebooting, etc.)
              There must be some interval (around 1 min in real time, including the time watching ads) between ad boxes. If you open the next ad box too soon, it will give only some golds, not ad.

              Comment


                #8
                Yes, I have seen up to three boxes drop simultaneously from the same mob, overlapping each other. I will click one and then move off and come back for the next and repeat for the third. Gems are worth more than a handful of gold! When I use a timed Booster, I am less willing to trade the time...

                Comment


                  #9
                  Originally posted by Alica2122 View Post

                  There must be some interval (around 1 min in real time, including the time watching ads) between ad boxes. If you open the next ad box too soon, it will give only some golds, not ad.
                  Yeah, I know about the cooldown. If a box drops too soon, I'll circle back to it after killing some mobs, or just waiting (unless on boosters, as lmcelhiney said above). I'm talking about when the ad boxes simply stop dropping at all. I'll do usually one more run to make sure, but then it's back to the whole uninstall/reinstall cycle...

                  Comment

                  Working...
                  X